Note: Following the release of the PDFImport Neo plugin in parallel with CorelCad 2020 SP0, the PDFImport plugin has been retired. For more information concerning the PDFImport Neo plugin, please visit https://www.graebert.com/cad-software/plugins-for-corelcad/

As explained here, the retirement of the first generation of the PDFImport plugin, and subsequent replacement by the new PDFImport Neo raised some questions from users with Perpetual License of the plugin, regarding the entitlement/use of the plugin in more recent/subsequent CorelCad versions.

We do our best efforts to ensure forward compatibility for our plugins, but the natural evolution of a software and of the APIs in CorelCad imply that from time to time a new version, or a new generation of the plugin has to be released. This is especially true for a plugin that, by definition, relies on the technology and licensing of a base software which technology is also significantly evolving. In the specific case of PDF Import for CorelCad, we have released a total new generation of the product. Hence the new name Neo.

When you buy the PDF Plugin in our estore it is specified for which version of CorelCad it was designed for.

For clarification:

  • PDF Import Plugin (or PDF Import Neo for that matter) versions are version specific, meaning that if updating CorelCad, you will need to download and install the correspondent plugin version. (Note that it is recommended to uninstall any previous versions of PDF-Import for CorelCad via the Control Panel of Windows before installing the more recent version of the plugin).
  • A (PDFImport) Perpetual License is valid without time limitation, and you are entitled to software updates for 12 months (Maintenance).
  • Reaching this date (Maintenance Expiry Date), you will be able to continue to use the plugin in up to the last CorelCad version available at the time of the maintenance expiry date.
  • Passing this period, If you want to update the CorelCad version installed (and use the correspondent PDFImport or PDFImport Neo plugin), you will need to renew the service.

Did this answer your question?