Please find the latest download links of ARES Commander 2022 below.

Note: In early 2021, we have changed our product naming convention: The products including 2022 in the product name were released during the 2021 calendar year, and ARES Commander 2022 SP0 follows ARES Commander 2019 SP3 in the product release sequence.

Note: From ARES Commander 2022 SP2.1 version onwards, ARES Commander will only be available for 64-bit architecture.

Windows Installer

ARES Commander 2022 SP0 for Windows ( 64-bit)
ARES Commander 2022 SP0 for Windows ( 32-bit)

ARES Commander 2022 SP1 for Windows ( 64-bit)
ARES Commander 2022 SP1 for Windows ( 32-bit)

ARES Commander 2022 SP1.1 for Windows ( 64-bit)
ARES Commander 2022 SP1.1 for Windows ( 32-bit)

ARES Commander 2022 SP2.0 for Windows ( 64-bit)
ARES Commander 2022 SP2.0 for Windows ( 32-bit)

ARES Commander 2022 SP2.1 for Windows ( 64-bit)
ARES Commander 2022 SP2.1 for Windows ( 32-bit)

macOS Installer

ARES Commander 2022 SP0 for MAC OS ( 64-bit)

ARES Commander 2022 SP1 for MAC OS ( 64-bit)

ARES Commander 2022 SP1.1 for MAC OS ( 64-bit)

ARES Commander 2022 SP2.0 for MAC OS ( 64-bit)

ARES Commander 2022 SP2.1 for MAC OS ( 64-bit)

Linux Installer

ARES Commander 2022 SP0 for Linux .deb ( 64-bit) for Ubuntu or Debian
ARES Commander 2022 SP0 for Linux .rpm ( 64-bit) for Suse Linux or Fedora
ARES Commander 2022 SP0 for Linux .tbz2 ( 64-bit) for other Distributions

ARES Commander 2022 SP1 for Linux .deb ( 64-bit) for Ubuntu or Debian
ARES Commander 2022 SP1 for Linux .rpm ( 64-bit) for Suse Linux or Fedora
ARES Commander 2022 SP1 for Linux .tbz2 ( 64-bit) for other Distributions

ARES Commander 2022 SP1.1 for Linux .deb ( 64-bit) for Ubuntu or Debian
ARES Commander 2022 SP1.1 for Linux .rpm ( 64-bit) for Suse Linux or Fedora
ARES Commander 2022 SP1.1 for Linux .tbz2 ( 64-bit) for other Distributions

ARES Commander 2022 SP2.0 for Linux .deb ( 64-bit) for Ubuntu or Debian
ARES Commander 2022 SP2.0 for Linux .rpm ( 64-bit) for Suse Linux or Fedora
ARES Commander 2022 SP2.0 for Linux .tbz2 ( 64-bit) for other Distributions

ARES Commander 2022 SP2.1 for Linux .deb ( 64-bit) for Ubuntu or Debian
ARES Commander 2022 SP2.1 for Linux .rpm ( 64-bit) for Suse Linux or Fedora
ARES Commander 2022 SP2.1 for Linux .tbz2 ( 64-bit) for other Distributions

System Requirements

Minimum

  • 64-bit version: Microsoft® Windows® 8.1 or Windows 10 (with latest Updates and Service Packs)

  • 32-bit version: Microsoft® Windows® 8.1 or Windows 10 (with latest Updates and Service Packs)

  • Intel® Core™ 2 Duo, or AMD® Athlon™ X2 Dual-Core processor

  • 1.5 GB free hard disk space depending on accessory applications installed

  • 4 GB RAM

  • 3D Graphics accelerator card with OpenGL version 1.4

  • Display with 1280 x 768 pixels resolution

  • Mouse

Recommended

  • 64-bit version: Microsoft Windows 10 (with latest Updates and Service Packs)

  • Intel® Core™ i5 processor, AMD Athlon/Phenom™ X4 processor, or better

  • 1.5 GB free hard disk space depending on accessory applications installed

  • 8 GB RAM

  • 3D Graphics accelerator card with OpenGL version 3.2 or better

  • Full HD monitor

  • Wheel mouse, or 3D mouse

  • macOS v10.14 (Mojave), v10.15 (Catalina), or v11.0 (Big Sur)

  • Mac® with Intel® Core™ 2 Duo processor or better

  • 4 GB of RAM (8 GB or more recommended)

  • 1.5 GB of available hard-disk space for installation

  • 3D Graphics accelerator card with OpenGL version 1.4 (OpenGL version 3.2 or better recommended)

  • Display with 1280 x 768 pixels resolution, or better

  • Mouse

  • Ubuntu® 18.04 LTS and 20.04 LTS, Fedora® 33

  • Intel® Core™ 2 Duo, AMD® Athlon™ X2 Dual-Core processor, or better

  • 4 GB of RAM (8 GB recommended)

  • 1.5 GB of available hard-disk space for installation

  • 3D Graphics accelerator card with OpenGL version 1.4 (OpenGL version 3.2 or better recommended)

  • Display with 1280 x 768 pixels resolution, or better

  • Mouse (Wheel mouse recommended)

Note: Product activation requires a network interface card.

Windows Terminal Servers are not supported.

Did this answer your question?