The Drawing Recovery Manager recovers drawings files if the system terminates unexpectedly, such as from a power failure, hardware issue, or software problem. The Drawing Recovery Manager palette opens the next time you start the application.

You can also use the DrawingRecovery command when you experience difficulties opening an existing drawing or if you want to check whether recoverable drawing files exist on your computer.

The Drawing Recovery Manager palette contains three sections:

Palette Area

Recovery Files tree view
Displays the files to recover as root entry. For each file the available autosave and backup files are listed.

Details list
Displays details about the drawing file: File name, folder, creation date and time, last saved date and time, file size, and the name of the user who last edited the file.

Preview area
Displays a preview of the drawing file.

You can use these toolbar buttons at the top of the palette:

Button

Details View Toggle
Turns on and off the Details area of the palette.

Preview Toggle
Turns on and off the Preview area of the palette.

The DrawingRecovery Manager supports these file types:

File Type

.dwg, .dws, .dwt
Drawing files, Drawing Standard files, Drawing Template files. These files are recoverable.

.ds$
Autosave files. These are backup files created automatically from time to time. Use the Options command to specify the number of minutes between automatic saves the extension for autosave files: in the Options dialog box, click System Options > Autosave & Backup.

.bak
Backup files. These files are created in the same folder as the current drawing file every time that you manually save a drawing file. Use the Options command to turn on and off the creation of backup files: in the Options dialog box, click System Options > Autosave & Backup.

filename_recover_yyyy-mm-dd.dwg
Recovery files. These files result from an unexpected failure or crash where filename represents the original file name, and yyyy-mm-dd specifies the date when the problem occurred.

To recover drawings with the Drawing Recovery Manager:

  1. Do one of the following:

Click File > Drawing Recovery Manager on the menu.

Click Manage > Drawing Recovery Manager on the Application Menu.

Type DrawingRecovery at the command prompt.

2. On the palette, in Recovery Files, use these options:

Execution

Select a root file name entry, then right-click Open All (or double-click the root entry).
Opens all files which exist for the root entry. To recover one of the opened files, save it as .dwg file.


Select a file name below the root entry, then right-click Open (or double-click the file name).
Opens the specified file. To recover the file, save it as .dwg file. Select a file name below the root entry, then right-click Properties. Displays the drawing file Properties dialog box provided by the operating system.

Select a root file name entry, then right-click Remove.
Removes the file entry from the recovery list. Use this option if you do not need to recover the file. The autosave and backup file are maintained. The recovery file is deleted.

To hide the Drawing Recovery Manager palette:

Do one of the following:

  • Type HideDrawingRecovery at the command prompt.
  • Click the Close Palette button.

Note: If you close the Drawing Recovery Manager before resolving all affected drawings, use the Drawing Recovery command to reopen the palette.

Note: For more information about autosave and backup options, see the Help file topic “Setting Automatic Save and Backup Options”

Access

Command: DrawingRecovery

Menu: File >Drawing Recovery Manager

Application Button: Manage > DrawingRecovery Manager

Did this answer your question?